[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[atomic-devel] Trying to automate installing ProjectAtomic

Hey everyone!

As part of our one of our hack days at Chef, we decided that we should automate the installation/bootstrap of ProjectAtomic[1]. Fair warning, it’s not production ready by any standard, so please take a look but don’t push it out to production…yet. Again, fair warning, DON’T USE THIS IN PRODUCTION.

Ok, done with the disclaimers, i’d like to ask some help us getting past the last mile.

Most, if not all of the machines we’re going to leverage are headless GUI-less machines, we want to leverage virt-install[2]. It seems there is an article[3] on this, but we’ve tried every way we could think of and we couldn’t get it to work. The machine shows up in virsh list, but if you connect with the console it just says “Escape Character ^]” and just sits there.  

We’ve confirmed that both isos work as expected, converted it to a VirtualBox image and booted it and it worked as expected, it just seems like something building the boot order with virt-install? We’re at a loss here, and greatly appreciate any  direction.

Oh, this was on BOTH CentOS 7 and Fedora 21. (Fedora 22 wasn’t playing nice with our setup at the time).

Thanks in advance,

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]