[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[atomic-devel] Issues with CentOS Atomic Image

I tried to use the CentOS image [1] tonight. I noticed several issues
that may be known but I didn't see them in http://bugzilla.centos.org.

1 - I had to use 'runcon -r system_r -t install_t rpm-ostree upgrade'
    see the bug for Fedora at [2]. I think you guys already know about

2 - I kept getting an DNS error half way through the upgrade:

    -bash-4.2# runcon -r system_r -t install_t rpm-ostree upgrade
    Updating from: centos-atomic-host:centos/7/atomic/x86_64/cloud-docker-host

    Receiving objects: 36% (1494/4147) 768.9 kB/s 69.2 MB
    error: Error resolving 'buildlogs.centos.org': Name or service not known
3 - I tried to work around the dns issue by doing:

    -bash-4.2# echo ' buildlogs.centos.org' >> /etc/hosts

    This doesn't work though. Seems like we are ignoring /etc/hosts
    for some reason. nssswitch.conf looks right to me:

    -bash-4.2# cat /etc/nsswitch.conf | grep ^hosts
    hosts:      files dns myhostname

Any thoughts on these issues?

[1] - http://buildlogs.centos.org/rolling/7/isos/x86_64/CentOS-7-x86_64-AtomicHost-20150228_01.qcow2.xz
[2] - https://bugzilla.redhat.com/show_bug.cgi?id=1061064

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]