[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [atomic-devel] cri-o, buildah and skopeo packages available via Ubuntu PPA and CentOS Virt SIG

`sudo crioctl image list` hangs while downloading images (maybe it's only the first image)?  Turned on crio, started openshift, before the first image was pulled it hung when I tried to image list, but subsequent ones worked fine.

On Wed, Jul 5, 2017 at 2:54 PM, Antonio Murdaca <runcom redhat com> wrote:

On Jul 5, 2017 8:47 PM, "Clayton Coleman" <ccoleman redhat com> wrote:
On centos-7.3 ish:

[vm]$ sudo crio --debug
DEBU[2017-07-05 18:47:09.094408134Z] [graphdriver] trying provided driver "overlay2"
FATA[2017-07-05 18:47:09.096470565Z] driver not supported

post install.   Something special I have to do to get overlay2 working on centos?

This is probably missing a configuration option in /etc/crio/crio.conf 

Where is the dist-git for cri-o in centos? I might check it and fix it. 

Clayton, you should add this under "storage_option" in cri-o configuration file to get rid of that failure:


On Wed, Jul 5, 2017 at 1:57 PM, Lokesh Mandvekar <lsm5 fedoraproject org> wrote:
Hi list,

I have packaged up cri-o, buildah and skopeo for Ubuntu and CentOS. To get
them, just do:

(On Ubuntu 16.04.2 LTS and 17.04, install the Project Atomic PPA)
% sudo apt-add-repository ppa:projectatomic/ppa
% sudo apt-get update
% sudo apt-get install cri-o buildah skopeo

(On CentOS 7, install the Virt SIG repo)
% sudo yum install https://lsm5.fedorapeople.org/centos-release-container-1-3.el7.noarch.rpm
% sudo yum install cri-o buildah skopeo

Reviews/feedback/bugs appreciated :)
Freenode, OFTC: lsm5

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]