[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [atomic-devel] Fedora && cloud-init [SOLVED]

Hummm... It seems I've found the culprit...

I'm using the "no cloud" plugin/data source for cloud-init, providing an cdrom ISO image with the relevant files.

The configs were not read at all during bootup, the reason being that the ISO image _needs_ to have a volume label for it to be mounted!

In the official documentation:

this is _not_ stated _explicitly_, even if the examples show this actually.
If this is the case it would be helpful to say that in the docs (i.e. "you should provide a volume label for the iso image otherwise cloud-init wouldn't be able to mount it during the boot process").

Anyway you shouldn't need a volume label to mount a cdrom!
Is it a bug ?!

Can I ask if are expected any special names for the volume label ?


-- Marco 

On Mon, Nov 9, 2015 at 11:02 PM, Marco <foobar angus gmail com> wrote:
On Sun, Nov 8, 2015 at 5:44 PM, Brandon Jozsa <bjozsa gmail com> wrote:
I believe your cloud-init config isn't set up correctly?

That was my hypothesis, even if I've RTFM.
Thanks for replying.
Try and use an example like the one I've posted on my blog: http://www.jinkit.com/openstack-magnum-devstack-deployment/

I've used now a similar config like the one you suggest in your blog, but with no success.
Moreover I've tried to use the "runcmd" section. In the "user-data" file I've inserted at the end:

  - echo "********* DBG ***********"
  - ifconfig
  - cat /etc/passwd
  - cat /etc/shadow
  - echo "********* DBG ***********"

I've understood that when executed this output goes to the console ! I've recorded the virtual machine console output (I'm on Virtualbox) : I can see all the bootup process till the "login:" prompt but not DBG output is there in the console log of the machine.

How can I be sure that the "no cloud" plugin is executing? What should I look for in the logs?!

Then you can use authorized keys. (My recommendation is to use keys over passwords).
Yes - I would normally agree with you, but I'm one step before: I'm still trying to get a functioning image :)

It seems that the user-data file is not read at all.
Someone is using this image with cloud-init successfully ?

-- Marco

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]