[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [atomic-devel] Fedora 28 Atoimic Host RC 1.1 available for testing

On Thu, Apr 26, 2018 at 7:45 PM, Dusty Mabe <dusty dustymabe com> wrote:

On 04/26/2018 08:54 AM, Sinny Kumari wrote:
> On Thu, Apr 26, 2018 at 2:05 AM, Dusty Mabe <dusty dustymabe com <mailto:dusty dustymabe com>> wrote:
> The Atomic Host compose based on RC 1.1 is available for testing now.
> The toplevel directory is: https://kojipkgs.fedoraproject.org/compose/twoweek/Fedora-Atomic-28-20180425.0 <https://kojipkgs.fedoraproject.org/compose/twoweek/Fedora-Atomic-28-20180425.0>
> The cloud images are under the compose/AtomicHost/$arch/images/ directories.
> The ISO images are under the compose/AtomicHost/$arch/iso/ directories.
>> Tested Atomic Host RC 1.1:
>> * Both ISO and cloud images look good  on all arches
>> * AMIs are working as expected including openshift cluster set-up
>> * Ran couple of podman commands and it worked as expected on all arches,
>>   One thing I noticed that, since both docker and podman are available on host,
>>   running "podman run -t fedora bash" didn't have network connectivity
>>   inside container. So, I ran podman with option --net=host and network was fine
>>   later on.

Weird. I think I'm seeing the same thing. If I disable docker and reboot I get the
expected behavior. For now we can just advise to disable docker if they want
to use podman. It doesn't make a lot of sense to try to use both on the same system

Agree with you. I also tried other way:
On a machine with F28 RC 1.1 installed, I first installed podman and launched a container
using `podman run -t fedora bash` , network was fine. Next, I installed docker and launched
container using docker, now no network inside docker container. Looks like both conflict
each other.

Sinny can you open an issue for this in atomic-wg and we'll ask brent for input.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]