[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [atomic-devel] atomic install/run cockpit does not work on atomic-ws



I've installed them using

[root localhost ~]# rpm-ostree install htop cockpit-bridge cockpit-system cockpit-docker cockpit-networkmanager cockpit-ostree
[root localhost ~]# rpm-ostree ex livefs
[root localhost ~]# rpm-ostree ex livefs --replace

then run cockpit with

[root localhost ~]# sytemctl start docker
[root localhost ~]# sytemctl start sshd
[root localhost ~]# atomic install registry.fedoraproject.org/f27/cockpit
[root localhost ~]# atomic run --name cockpit registry.fedoraproject.org/f27/cockpit

and it worked

> cockpit has been more for managing servers I think so the needed bits aren't embedded in FAW.

I believe its bridge should be added (the same way we have sshd pre-installed) to have consistent experience
because the proper way to add more applications to atomic is via flatpak or docker/atomic
but cockpit won't work neither ways.

I have some questions

what is the command line that check for updates without applying the update? and list pending updates?
is it pull?


when an update came to atomic ws, it removed those (picture inlined, look at removals: 10 packages)

is there a way to carry those newly installed packages from the current layer into the updae?

rpm-ostree has all needed information to do this.

it knows they were added in the past
it knows they are still missing in the update
it knows how to merge (or rebase) them



‚Äč



On Fri, Mar 23, 2018 at 7:34 PM, Dusty Mabe <dusty dustymabe com> wrote:


On 03/23/2018 11:56 AM, Muayyad AlSadi wrote:
> hi,
>
> I've installed the latest atomic workstation on a vm
>
> I tried to run cockpit by typing
>
> atomic install registry.fedoraproject.org/f27/cockpit <http://registry.fedoraproject.org/f27/cockpit>
>
> but it gives
>
> cockpit-bridge must be installed on host
>
>
>
> is there a way to run cockpit on atomic workstation?


cockpit has been more for managing servers I think so the needed bits aren't embedded in FAW.

If you want you can layer in the same packages we include in FAH. They are listed here:

https://pagure.io/fedora-atomic/blob/master/f/fedora-atomic-host.json#_112-116


>
> BTW: I wrote a review in Arabic for atomic-ws, it's awesome. I'll translate it very soon. but I would like to include cockpit in the english version
>
> http://g0alkeeper.blogspot.com/2018/03/blog-post.html

Nice! Thanks for helping us reach another audience!

Dusty


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]